Der dritte Tag

Hauptkategorie: 8-Bitter
Erstellt: 23 Oktober 2011
Zugriffe: 1660

Schon ist wieder eine Woche vergangen. Die Ersatzteile liegen schon ein paar Tage herum, aber neben dem Projekt muss ich halt auch noch ein wenig arbeiten und Marc hatte auch gut mit seinem Physik-Leistungskurs zu tun...

Naja, die Teile sehen schon beide etwas anders aus, als die Originale. Der Gleichrichter ist leicht überdimensioniert ausgefallen und der Elko hat zwar denselben Durchmesser, ist aber ein Stück höher als der defekte. Schau'n mer mal, wie wir das dann in die Kiste einlöten.

 Der Elko passt - auch wenn er zu  hoch ist, das dürfte nachher schon ins Gehäuse reinpassen. Notfalls überlegen wir uns dazu noch was. Aber er ist erst mal drin.

Der Gleichrichter macht etwas mehr Probleme. Nach kurzem Anhalten ist der Weg klar: Die beiden Wechselspannungsleitungen werden an flexible Leitungen angelötet und kurz dahinter abgeknipst. Dann biegen wir noch vorsichtig einen der beiden Gleichspannungsdrähte um - und schon passt es. Um die Passgenauigkeit noch etwas zu erhöhen, gehen wir erst mechanisch, dann elektrisch an die Sache heran:

Der Anschluss des GR erfolgt über die beiden weißen Leitungen
Wir reinigen alle Bauteile, die wieder am Kühlkörper festgeschraubt werden müssen mit Waschbenzin und packen wieder ordentlich Wärmeleitpaste drauf - auch auf den noch nicht festgelöteten Gleichrichter, dessen zwei verbliebene Beinchen aber schon lose in der Platine stecken. Dann schrauben wir gemeinsam die Teile am Kühlkörper fest und ihn selbst an der Platine wie vorgesehen an.

Dann erst löten wir die Gleichspannungsbeinchen des GR fest. Wir haben die Erwartung, dass dadurch trotz der anderen Bauform eine möglichst gute Kopplung an den Kühlkörper besteht, aber ohne mechanische Spannungen zur Platine.

So - jetzt heißt es einschalten, zunächst mal ohne Last.

Whamm!

Ein Knall, ein Blitz - schnell wieder aus!

Es stinkt mal wieder nach Elektrolyt. Offensichtlich ist der nächste Elko hops gegangen. Haben wir bei den Versuchen am 2. Tag vielleicht einen getesteten Kandidaten falsch herum eingelötet?

Nach kurzer Suche ist einer als etwas gewölbt identifiziert und wird ausgelötet. Hmmm: Er liegt in der -12V Versorgung, die letzte Woche noch prima gefunzt hat.

Aber egal, der ist jetzt hin und stört nicht mehr. Ohne Last lassen wir das Netzteil wieder ans Netz gehen: Sieht gut aus, nichts stinkt, nichts kracht, nichts blitzt. Und die drei Versorgungsspannungen kommen auch an den richtigen Steckern raus. Super!

Also schließen wir zunächst mal eins der Floppy-Laufwerke an. Der Motor brummt los (warum eigentlich? Wir werden es bald wissen.), das sieht gut aus.

Dann:

PffffEs stinkt wieder und man sieht es qualmen: Was ist denn nun schon wieder? Auf der Netzteilplatine bildet sich unter einem weiteren (kleinen) Elko eine Elektrolyt-Pfütze. Also auch den noch auslöten, irgendwann sind sie dann ja wohl eh alle hin.

Aber wir lassen uns nicht abschrecken: NT wieder ohne Last an: Nix stinkt. Floppy dran: Yep, Motor läuft wieder an, alle Spannungen zumindest laut digitalem Messgerät sind OK. Na gut, dann etwas mehr Last: Das zweite Laufwerk wird angestöpselt. Panasonic hat dazu schon damals separate (und unterschiedlich lange) Versorgungsleitungen eingebaut.

Leichte Schrecksekunde: Es Kracht zwar nichts, es stinkt auch nicht mehr als vorher, aber der Motor des ersten Laufwerks sagt nichts mehr. Nach dezentem Rütteln an den Steckverbindungen geht er mal an, dann wieder aus. So langsam kommt mir eine Erinnerung: Die JD hatte damals eine geniale Hardware eingebaut bekommen, bei der der Diskettenmotor eine kurze Zeit lief, wenn man eine Diskette eingeworfen hat. Für Marcs Frage, wozu das denn diene, kann ich auch noch eine Antwort aus dem Gedächtnis kramen: Diskettenlaufwerke haben einen kegelförmigen Antrieb der Disketten, der in das "große" Loch der Diskette passen muss. Und das passt eben doch manchmal nicht so gut. Deshalb schmeisst ein gutes Laufwerk den Motor an, wenn man eine Diskette einwirft. Schließt man dann langsam das Laufwerk, wird durch den sich drehenden Antrieb die Diskette zentriert. Deshalb hieß das damals auch Zentrierlauf (oder so ähnlich).

Netzteil versorgt die beiden Laufwerke
Na und das war auch das ganze Geheimnis, denn die obere Diskette drückte eben manchmal den entsprchenden Kontakt.

Also gut, dann können wir ja leichte Last aufs Netzteil legen, indem wir immer wieder mal eine Diskette in jedem Laufwerk rein- und rausschieben (Frage von Marc: Sind das jetzt echte Floppies? Ja, sind sie. Und sie heißen Fünfeinviertelzöller. Aber dass sie soft-sektoriert sind und was das mit dem "kleinen" Loch in der Diskette zu tun hat, erkläre ich ihm ein anderes mal...).

Nach weiteren 10 Minuten gehen wir in die nächste Denkrunde: Können wir es wagen, das Mainboard anzuschließen? Die beiden Versorgungen mit aktuell defekten Elkos sind die +12V und die -12V. Die +12V sehen bei den Laufwerken ganz stabil aus (kurzzeitige Spitzen kann ich natürlich ohne Oszilloskop nicht erkennen), aber die -12V dürften unter Last schwingen. Meine Annahme, dass die -12V nur für die seriellen Schnittstellen benötigt werden, wird durch einen Blick in den Schaltplan zunichte gemacht. Leider werden die -12V noch mal runtergeregelt und werden von den dynamischen Speicherbausteinen verwendet. Und wenn die nicht ordentlich sind, spinnt der ganze Rechner, das weiß ich aus alten Tagen noch sehr gut.

Also ist erst mal wieder Warten auf einen geöffneten Elektronik-Shop angesagt.

Die beiden Elkos habe ich mir noch mal in Ruhe angesehen, da fällt mir etwas auf: Alle drei bisher defekten Elkos sind aus der Serie bis 50V - die Serie für kleinere Spannungen scheint wohl eher durchzuhalten. Das ist zwar keine Erklärung, gibt aber eine leichte Beruhigung, dass bei der nächsten Runde nicht wieder welche hochgehen.

Warten wir's ab...